Функции и Формулы

Как посчитать среднее значение в Google таблицах?

Как посчитать среднее значение в Google таблицах?

Когда мы ведем таблицу с данными по продажам — появляется нужда вывести среднее арифметическое столбцов со значениями. Это можно сделать 3 разными способами: формулами и встроенным функционалом в гугл таблицах.

Считаем среднее арифметическое через встроенный функционал в Google таблицах

У нас есть несколько столбцов с аналитикой по продажам за прошлый и текущий года в одном из маленьких интернет-магазинов, который меня попросили «реанимировать». Как сосчитать среднее арифметическое за текущий год в строке со средним чеком встроенным инструментов в гугл таблицах?

  • Нужно выделить диапазон с данными (строку или столбец).
  • В правом нижнем углу появится модальный список со встроенными функциями, на который нужно кликнуть левой кнопкой мыши.
  • В появившемся списке выбираем нужное значение.

Этот способ подходит когда данных мало, либо вы хотите одноразово узнать среднее значение по данным. Но что, если данные все время дополняются и надо постоянно мониторить ситуацию?

Считаем среднее арифметическое через функцию AVERAGE (СРЗНАЧ) в Google таблицах

Функция AVERAGE вычисляет среднее арифметическое аргументов (за исключением текстовых).

 =AVERAGE(value_1; [value_2; …])
 =СРЗНАЧ(значение_1; [значение_2; …])
  • Value_1 — обязательный аргумент. Первое значение, функция или диапазон для вычисления среднего арифметического значения.
  • [Value_2; …] — необязательный аргумент. Дополнительные значения, функции или диапазоны для вычисления среднего арифметического значения.

На примере в ячейке P25 прописана формула AVERAGE (СРЗНАЧ), где в качестве первого значения выбран диапазон ячеек (ячейки с C25 по N25).

 =AVERAGE(C25:N25)

Примечания

  • Несмотря на то, что по спецификации функция AVERAGE (СРЗНАЧ) не принимает более 30 аргументов, Google таблицы позволяют передавать ей произвольное количество аргументов.
  • Любой текст, встречающийся среди значений, будет проигнорирован. Если вы хотите, чтобы текстовые данные рассматривались как 0 (нуль), используйте функцию AVERAGEA (СРЗНАЧА).
  • AVERAGE (СРЗНАЧ) возвращает среднее значение среди всех переданных ей значений (то есть сумму всех значений, отнесенную к их числу). Для вычисления медианы используйте функцию MEDIAN (МЕДИАНА).

Стоит заметить, что если в ячейках будет стоять 0 (нуль) вместо пустой (как на примере), то среднее арифметическое будет учитывать эту ячейку, и данные будут с искажениями.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *