Функции и Формулы

Функция INDEX (ИНДЕКС) в Google таблице

Функция INDEX (ИНДЕКС) в Google таблице

Функция INDEX (ИНДЕКС) возвращает содержимое ячейки, находящейся на пересечении определенной строки и столбца в выбранной области гугл таблицы.

 =INDEX(array; [row]; [column]) - английская версия формулы
 =ИНДЕКС(ссылка; [строка]; [столбец]) - русская версия формулы
  • Array (Ссылка) — выбранный диапазон с искомой ячейкой.
  • [Row (Строка)] — номер строки в выбранной области, в которой искомая ячейка.
  • [Column (Столбец)] — номер столбца в выбранной области, в котором искомая ячейка.

В отличии от функции ИНДЕКС из Excel, в google таблицах формула имеет всего 3 аргумента, 2 из которых — необязательные. Работает по абсолютно схожему принципу, хотя и имеет ряд отличий:

Функция INDEX в Google таблице с указанием только первого аргумента

Если указать только ссылку (array) на интересующую область — формула отобразит всю область целиком, причем, в первой ячейке (в которой формула) будет отображаться информация из первой верхней левой ячейки (если выбранный диапазон имеет несколько столбцов), а остальная информация отобразится в нижних ячейках и ячейках правее (под ячейкой и правее ячейки с формулой).

Функция INDEX в Google таблице с указанием массива и строки

В ячейке D2 указана формула, ссылающаяся на область A2:B5 и строку 3 в этой области. Как видно, если указана только строка, то формула отобразит первое значение из 3й строки (Картофель), а правее запишет его количество.

Функция INDEX в Google таблице с указанием всех аргументов

На примере выбрана область таблицы, где мы будем искать данные — A2:B7; мы хотим отобразить данные из 4 строки; мы хотим отобразить данные со 2 столбца. Итог: 22, так как это значение находится на пересечении 4й строки и 2ого столбца.

Функция INDEX редко используется в качестве основной, чаще всего ее используют в связке с функцией MATCH (ПОИСКПОЗ). Комбинация настолько гибкая, что ею заменяют популярную функцию VLOOKUP (ВПР), так как комбинация функций INDEX и MATCH способна отображать данные из диапазона левее самой формулы, в то время как VLOOKUP так не может сделать.

Поделитесь пожалуйста в комментариях, где вы использовали только функцию INDEX и какие задачи вы через нее решали.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *