WooCommerce, Шаблоны Google Sheets

Как массово прикрепить картинки к товару?

Как массово прикрепить картинки к товару WooCommerce?

Файл конфигуратора для обработки картинок товаров

Создаем новый docs.google документ и озаглавливаем его по мануалу.
Нам нужен столбец Артикула (SKU), Название товара, Транслит Название товара, Ссылка на карточку товара, Ссылка на фото, Специальные ячейки с месяцем и годом, Столбец с количеством картинок к товару.

Транслитированные названия

В ячейку C3 вставляем следующую формулу:

=ЕСЛИОШИБКА(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(СТРОЧН(GOOGLETRANSLATE(B3;DETECTLANGUAGE(B3);"en")&ПРАВСИМВ(A3;ДЛСТР(A3)-ПОИСК("-";A3)+1));" ";"-");"+";"plus");"(";"");":";"");")";"");"№";"");" - ";"-");" x ";"-");".";"");"'";"");" & ";"-");"«";"");"»";"");" х ";"-");",";"");"")
  1. Формула переводит текст из колонки «Название товара (Name)» на английский язык.
  2. Превращает все буквы в строчные.
  3. Вместо пробелов между словами подставляет дефис.
  4. Удаляет все математические и прочие знаки.
  5. Цепляет часть Артикула (SKU) через дефис.

Ссылка на карточку товара

В ячейку D3 вставляем следующую формулу:

=ЕСЛИ(B3="";"";"https://ВАШ ДОМЕН.ru/ВАШ ПУТЬ ТОВАРА/"&C3&"/")

Формула сформирует URL, взяв стандартный путь от домена до ссылки продукции и прицепив на конце транслитированное название товара.

  1. Вместо «Ваш домен» — вписываем URL своего сайта.
  2. Вместо «Ваш путь товара» — параметр зависит от настроек WP (Настройки -> Постоянные ссылки).

Ссылка на фото

В ячейку E3 вставляем следующую формулу:

=ЕСЛИ(G3="";"";ЕСЛИ(G3=10;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg"&","&F3&"-6.jpg"&","&F3&"-7.jpg"&","&F3&"-8.jpg"&","&F3&"-9.jpg"&","&F3&"-10.jpg";ЕСЛИ(G3=9;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg"&","&F3&"-6.jpg"&","&F3&"-7.jpg"&","&F3&"-8.jpg"&","&F3&"-9.jpg";ЕСЛИ(G3=8;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg"&","&F3&"-6.jpg"&","&F3&"-7.jpg"&","&F3&"-8.jpg";ЕСЛИ(G3=7;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg"&","&F3&"-6.jpg"&","&F3&"-7.jpg";ЕСЛИ(G3=6;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg"&","&F3&"-6.jpg";ЕСЛИ(G3=5;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg"&","&F3&"-5.jpg";ЕСЛИ(G3=4;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg"&","&F3&"-4.jpg";ЕСЛИ(G3=3;F3&"-1.jpg"&","&F3&"-2.jpg"&","&F3&"-3.jpg";ЕСЛИ(G3=2;F3&"-1.jpg"&","&F3&"-2.jpg";ЕСЛИ(G3=1;F3&".jpg")))))))))))

Ссылаясь на ячейки с годом и месяцем, и на ячейку с маской картинки — формируется список из URL, относительно заявленного количества картинок.
Список используется потом при массовом импорте информации к карточкам товаров.

Маска URL картинки

В ячейку F3 вставляем следующую формулу:

=ЕСЛИ(B3="";"";"https://ВАШ ДОМЕН.ru/wp-content/uploads/"&$F$1&"/"&$F$2&"/"&C3)

Формула формирует маску из URL вашего домена + папки с картинками на сервере + транслитированного названия карточки товара.

Логика структуры обработки картинок

Чтобы досконально разобраться в оптимизации работы с картинками, нужно понять простую логику последовательности действий.

  1. Доскональное заполнение данных в файл склада.
  2. Покарточная обработка картинок (редактирование фото к товару происходит при обработке каждой карточки товара отдельно).
  3. Фиксация количества картинок к товару в специальном поле.
  4. Внимание с работой даты, месяца и года.
  5. Присваивание картинкам транслитированных (или переведенных на английский язык) названий.
  6. Импорт картинок, с покарточным заполнением мета тегов.

Заполняем данные

Работа импорта товаров в интернет-магазин на WooCommerce начинается с заполнения информацией о товарах в файл склада. На такой базе можно построить целую систему с шаблоном импорта всех видов товаров не только в магазин, но формировать списки для размещения товаров на маркетплейсах.

Минимальная информация: Артикул (SKU), Название товара, Цена, Характеристики, Габариты упаковки, вес и т.д. Эти данные помещаются в отдельные столбцы и используются в разных шаблонах и списках.

Обработка картинок держится на артикуле (SKU) и названии товара.

Как правильно создать Артикул (SKU)?

Редактирование картинок к товарам

После заполнения файла склада информацией от поставщика — скачиваем покарточно картинки к нему (не всегда можно понять к какому товару какое фото отнести), лучше всего обрабатывать файлы: 1 SKU — обработка картинок к этому товару.

Картинки к товару сжимаются любым онлайн редактором. Уравниваются параметры: Длина и Ширина, чтобы сетка товаров в интернет-магазине не съезжала.

Фиксация данных по картинкам

После того, как картинки отредактированы, происходит фиксация их количества и предполагаемой даты импорта в медиа библиотеку в отдельных специальных полях шаблона.

Присваиваем title картинкам

Из поля «Транслитированное название» копируем информацию и присваиваем ее ряду фото к товару. Первая картинка из ряда — главное фото, остальные — галерея.

Импорт картинок и заполнение мета тегов

После полной обработки картинок, импортируем ряд в медиа библиотеку и заполняем мета теги: Атрибут alt, Название, Описание, взяв их из файла склада (Название карточки товара).

Итог: избежать монотонной работы руками не удастся, но значительно облегчить некоторые действия и сэкономить кучу времени — получится.

Пожалуйста, не забудьте подписаться на мой Youtube канал, там самые свежие видео с файлами и идеями!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *