WooCommerce, Шаблоны Google Sheets

Шаблон для массового импорта простых товаров

Шаблон для импорта простых товаров в WooCommerce

Чтобы без плагинов совершить массовый импорт товаров в интернет-магазин на wordpress, рассмотрим следующий довольно простой вариант:

Создаем файл excel/docs

Присваиваем правильные имена столбцам

Есть очень хорошая статья на github, где перечислены все основные названия полей.

Даем названия полям, значения которых мы хотим импортировать, прописав заранее формулы там где нужно. Это в будущем сильно облегчит импорт в том случае, если товар в Вашем магазине не имеет тех или иных значений.
При импорте, все поля уже будут заданы, а пустые поля сразу будут помечены «Не импортировать».

A1 SKU Артикул
B1 =ЕСЛИ(B2=»»;»»;»ID») ID товара в базе woocommerce
C1 Name Название карточки товара
D1 Type Тип товара (simple,variable,variation,virtual)
E1 Regular Price Цена товара
F1 Categories Категория товара
G1 Published Опубликован или нет (1,0,-1)
H1 =ЕСЛИ(H2=»»;»»;»Short Description») Короткое описание товара
I1 =ЕСЛИ(I2=»»;»»;»Description») Полное описание товара
J1 =ЕСЛИ(J2=»»;»»;»Upsells») Похожие товары/Товары из набора
K1 =ЕСЛИ(K2=»»;»»;»Cross-sells») Товары, отображаемые в корзине (сопутка к основному: батарейки к роботу/пульту и т.д.)
L1 =ЕСЛИ(L2=»»;»»;»Length») Длина товара/Длина упаковки товара
M1 =ЕСЛИ(M2=»»;»»;»Width») Ширина товара/Ширина упаковки товара
N1 =ЕСЛИ(N2=»»;»»;»Height») Высота товара/Высота упаковки товара
O1 =ЕСЛИ(O2=»»;»»;»Weight») Вес товара/Вес товара с упаковкой
P1 Images Картинка товара
Q1 =ЕСЛИ(И(Q2=»»;Q3=»»);»»;»Мета: _woodmart_product_hashtag») Метатег/Дополнительное поле (добавляется, если тема позволяет, можно пропустить)
R1 =ЕСЛИ(И(R2=»»;R3=»»);»»;»Мета: _woodmart_product_video») Метатег/Дополнительное поле (добавляется, если тема позволяет, можно пропустить)
S1 =ЕСЛИОШИБКА(ЕСЛИ(S2=»»;»»;»Attribute 1 Name»);»») Имя Атрибута товара (Например: Бренд)
T1 =ЕСЛИ(S1=»»;»»;»Attribute 1 Value(s)») Значение атрибута (Например: Moluk)
U1 =ЕСЛИ(S1=»»;»»;»Attribute 1 Visible») Видимость атрибута (1,0)
V1 =ЕСЛИ(S1=»»;»»;»Attribute 1 Global») Глобальный/Индивидуальный атрибут (1/0)

 

Прописываем столько атрибутов, сколько у ваших товаров есть или нужно прогрузить в конкретной ситуации, изменяя номер атрибута в формулах по примеру выше.

Заполняем формулами поле конфигуратора

В зависимости от заполнения нашего склада, заполняются и наши ячейки к товару. Если ячейки в складе не заполнены, то во вкладке просто будет пусто. Это реализовано следующими формулами:

A2 =IFERROR(INDEX(‘Склад’!B:B;SMALL(IF(‘Склад’!C:C=»»;ROW(‘Склад’!B:B);»»);’Склад’!A3));»»)
B2
C2 =IF(A2=»»;»»;VLOOKUP(A2;’Склад’!B:D;3;0))
D2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AR;43;0))
E2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:F;5;0))
F2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:W;22;0))
G2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AS;44;0))
H2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AL;37;0))
I2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AM;38;0))
J2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AJ;35;0))
K2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AK;36;0))
L2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:Q;16;0))
M2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:R;17;0))
N2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:S;18;0))
O2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:T;19;0))
P2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AP;41;0))
Q2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AT;45;0))
R2 =ЕСЛИ(A2=»»;»»;ВПР(A2;’Склад’!B:AU;46;0))
S2 =ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;’Склад’!B:V;21;0)=»»;»»;’Склад’!$V$1);»»)
T2 =ЕСЛИОШИБКА(ВПР(A2;’Склад’!B:V;21;0);»»)
U2 =ЕСЛИ(S2=»»;»»;1)
V2 =ЕСЛИ(S2=»»;»»;1)

 

После того, как мы заполнили во вкладке склада поля с информацией по товарам, она перенесется во вкладку импорта, основываясь на значения поля ID.

Формула работает так:
По столбцу В идет сравнение значений, если формула понимает, что ID не указан у товара, значит он не заведен в базу интернет-магазина.
Выделяется строка и переносится во вкладку «Импорт».
Так формула переносит все значения в строке, если нет ID.

Если нет информации в какой-то из ячеек, она просто игнорируется системой.
Если информации нет в принципе у ряда товаров, то сам столбец игнорируется, а система при импорте не будет обращать на это никакого внимания.

Скачиваем файл для импорта

Если Вы делали таблицу на excel, то копируете все из вкладки импорт и вставляете все в новый файл гугл докс, вставив только значения (а не формулы), после чего — скачиваете в расширении CSV и импортируете по мануалу ниже.

Импорт файла через встроенную систему WooCommerce

В появившемся окне еще раз бегло проверяете информацию и жмете «Начать импорт».
Радуетесь результату.

#wordpress #woocommerce

Комментарии к статье: “Шаблон для массового импорта простых товаров

  1. Патрушев Сергей:

    Спасибо за шаблон!

  2. Игорь:

    Круто! Благодарен за материал и готовый шаблон!

  3. Радмир:

    Файл скопировал, все получилось! Спасибо, мужик!

  4. Евгений:

    Спасибо за материал.

  5. Елена П.:

    Спасибо за информацию и шаблон! Подписалась на обновления и ютуб канал!

  6. Евгений Марченков:

    Благодарен за гугл таблицу, то что надо!

  7. Андрей:

    Спасибо за шаблон импорта!

  8. Наталья:

    Как научиться писать формулы?

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *