Шаблоны Google Sheets

Шаблон-конфигуратор для импорта в Яндекс Маркет

Шаблон-конфигуратор для импорта в Яндекс Маркет

Для расширения каналов продаж и для привлечения коммерческого трафика на сайт можно разместить товары в маркетплейс от Yandex.

У вас уже есть интернет-магазин на wordpress с заведенными товарами и вам нужно загрузить эти товары в Яндекс Маркет.

Присваиваем товарам категории Яндекс Маркет

Чтобы товарам были верно присвоены категории на Маркете, отведем под них дополнительный столбец (рядом со столбцом категорий нашего интернет-магазина).

Сам список категорий доступен из официального репозитория Яндекс. Скачиваем файл, обрабатываем.

Рабочая складская среда

Создаем по своему шаблону или берем универсальный образец и дополняем новой вкладкой по мануалу из официального видео от YaMarket:

Заполнив все поля для маркета в новой вкладке, приступаем к написанию удобного автоматического конфигуратора.

Конфигуратор для Market

Идея заключается в автоматическом переносе нужной информации из рабочей среды склада во вкладку, которую мы потом будем копировать и вставлять в шаблон.

Товары периодически могут заканчиваться или поставки придут с задержкой, а по правилам Маркета, максимальное время ожидания товара (на момент написания данного материала) составляет 60 суток.
Поэтому нам нужно учесть данный нюанс и опционально оставить возможность управлять ассортиментной матрицей наших товаров.

Поля со звездочкой — обязательные, я дополнительно выделил другим цветом. Эта информация нам и понадобится. Ее же описывает официальный представитель от Яндекс Маркет в видео выше.
Остальные поля тоже можно заполнять, но они не играют никакой сильной роли для импорта.

Заполняем формулами ячейки

Чтобы информация обновлялась автоматически каждый раз после обработки Вами актуальности прайса, заполняем соответствующие ячейки следующими формулами:

A2 =ЕСЛИОШИБКА(ИНДЕКС(‘Склад’!C:C;НАИМЕНЬШИЙ(ЕСЛИ(‘Склад’!Y:Y=»Загрузить»;СТРОКА(‘Склад’!C:C);»»);’Склад’!A3));»»)
B2 =ЕСЛИОШИБКА(ЕСЛИ(ВПР(A2;’Склад’!C:E;3;0)=0;»На заказ»;»В наличии»);»»)
C2 =ЕСЛИ(A2<>»»;»Есть»;»»)
F2 =ЕСЛИ(A2<>»»;»Нет»;»»)
I2 =ЕСЛИ(A2<>»»;»Нельзя»;»»)
J2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:AO;39;0);»»)
K2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:Z;24;0);»»)
L2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:D;2;0);»»)
M2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:X;22;0);»»)
N2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:F;4;0);»»)
P2 =ЕСЛИ(A2<>»»;»RUR»;»»)
Q2 =ЕСЛИ(A2<>»»;ЕСЛИОШИБКА(ЛЕВСИМВ(СЖПРОБЕЛЫ(ВПР(A2;’Склад’!C:AP;40;0));
ПОИСК(«,»;СЖПРОБЕЛЫ(ВПР(A2;’Склад’!C:AP;40;0)))-1);СЖПРОБЕЛЫ(ВПР(A2;’Склад’!C:AP;40;0)));»»)
R2 =ЕСЛИ(A2<>»»;ВПР(A2;’Склад’!C:AL;36;0);»»)
U2 =ЕСЛИ(A2<>»»;»Есть»;»»)
Y2 =ЕСЛИ(A2<>»»;»Нет»;»»)

Копируем данные в прайс-лист Excel YMarket

После того, как мы заполнили поля конфигуратора формулами, у нас появится информация из поля склада, со всей нужной для Маркета информацией в заданной строгой последовательности, какую нам задал сам Яндекс.

1. Регистрируем наш магазин на Маркете, заполнив всю информацию об организации.
2. В разделе «Ассортимент» появится модальная вкладка, где нам нужно выбрать «Прайс-листы».

3. Скачиваем предложенный шаблон.

4. Открываем его. В нем 3 вкладки (Правила, Описание полей и Нужная нам). Будет всплывающий попап с предупреждением о том, что ничего нельзя удалять, менять местами и т.п. А еще оповещение о том, что работают формулы.
5. Открываем вкладку для импорта в Маркет в нашем конфигураторе, где мы заполняли формулами ячейки и копируем все-все ячейки до самого конца.

6. Вставляем только значения скопированной информации (правая кнопка мыши -> вставить только значения) из вкладки нашего конфигуратора в скачанный файл-шаблон от Яндекс Маркета.

7. Жмем «Сохранить файл» в том же формате.
8. Вставляем обновленный прайс-лист от Яндекс Маркета в личном кабинете.
9. Ждем проверку, если все сделали правильно (по моему мануалу) — проверка будет пройдена и через 4 часа пойдут показы ваших товаров.
Если где-то совершили ошибку, будет подсветка где именно и что нужно исправить.

В общем-то, данная процедура занимает у меня меньше минуты. Зашел в ЛК маркета -> скачал шаблон -> скопировал из вкладки всю инфо -> вставил в шаблон -> сохранил -> вставил в маркет.

Ссылка на шаблон docs.google с примером.

#wordpress #woocommerce

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *