Шаблоны Google Sheets

Оптимизируем процесс закупки товаров

Как оптимизировать работу с заказами в интернет-магазине?

Зачем нужно оптимизировать работу с товарами?

Даже когда у вас пара заказов в день, в конце недели вы с легкостью можете запутаться каких товаров, сколько и у какого поставщика их покупать.

С ростом заказов проблема будет становиться все острее и начнутся проблемы с отказами (клиенты не любят долгой обработки заказов и уходят к конкурентам).

Чтобы снизить количество отказов в интернет-магазине и сильно упростить жизнь человека, занимающегося закупками — рассмотрим вариант существенной оптимизации процесса обработки заказов и сортировки товаров в этих заказах по поставщикам.

Создаем файл склада наших товаров

Для комфортной работы мы должны поместить подробную информацию о наших товарах в какую-то понятную и простую среду. Я использую docs.google. Можно воспользоваться любыми другими online/offline таблицами, сервисами и т.д.

Как создать и заполнить файл для склада?

Это очень сэкономит и оптимизирует работу с товарами от разных поставщиков (у меня их более 50) и поможет быстро обрабатывать входящую информацию по каждому артикулу (SKU) в любой момент времени.

А еще, это информационная база, на которой строится вся работа по встраиванию ваших товаров в экосистемы маркетплейсов и прочих сервисов e-commerce.

Создаем вкладку Заказы

Фиксируем все наши заказы из интернет-магазина. Это можно сделать руками, либо выгружать плагинами и импортировать данные по заданному нами шаблону.

Обратите внимание, что часть данных статична, а часть подтягивается формулами из вкладки склада, которая заполнена данными о товарах, их ценами, расположением на складе и т.д. (это в случае ручного управления заказами). Если у вас автоматически идет выгрузка данных — формулы не нужны.

В столбце А нумеруем строки 1,2,3,4,...
На эту нумерацию будет ссылаться другая формула
Ячейка С2: =ЕСЛИ(O2="Ждет";"Заказать";"")
Если в статусе товара в столбце О - будет слово "Ждет", то в столбце С, напротив SKU (артикула) будет пометка - "Заказать", если что-то другое или ничего не будет - то ячейка будет пустой. Эти данные мы соберем и отобразим в другом поле в следующей вкладке.
Ячейка E2: =ЕСЛИОШИБКА(ВПР(D2;'Склад'!B:G;6;0);"")
Формула ссылается на ячейку D2, в ней отображается SKU (артикул) заказанного клиентом товара и ищет во вкладке Склад название, соответствующее этому SKU, если в ячейке D2 ничего не будет выведено, то ячейка с названием товара будет пустой.
Ячейка F2: =ЕСЛИОШИБКА(ВПР(D2;'Склад'!B:I;8;0);"")
Аналогичная формула, как в ячейке с названием, только тут выводится цена товара, которая берется все с той же вкладки Склад, которую Вы заполните информацией о вашем товаре.
Ячейка G2: руками пишем какое количество заказал клиент
Ячейка H2: F2*G2
Получаем общую сумму за товары данного SKU (артикула)
Ячейка I2: =ЕСЛИОШИБКА(ВПР(D2;'Склад'!B:P;15;0);"")
Формула выводит значение коробки или полки, на которой расположен ваш товар. Карта склада очень облегчает жизнь предпринимателю на складе. Можно быстро найти нужный SKU, предварительно подписав номер коробки и указав его в соответствующем поле во вкладке Склад, напротив SKU (артикула).
Ячейка J2: =ЕСЛИОШИБКА(ВПР(D2;'Склад'!B:Q;16;0);"")
Аналогично предыдущей формуле. У меня таких столбца с номерами полок - 4 шт, у Вас может быть сколько угодно.
Ячейка K2,L2,M2: Заполняете по своему усмотрению, я сюда пишу ФИО, Mail, Номер телефона.
Ячейка N2: Сюда заполняете полную сумму всех товаров и доставки.
Ячейка O2: В эту ячейку вы указываете статус, который будет влиять на ячейку C2, выше формула, которая указывает нам на то, если стоит "Ждет", то укажется "Заказать" и товар пойдет в зачет на формирование списка закупки к поставщику. Или любой другой, для отслеживания статуса заказа. Так же, напротив суммы за все товары вы будете указывать сумму, которую с вас взяла курьерская служба.
Ячейка O2: =N2-O2
Тут будет итоговая сумма за заказ за вычетом стоимости доставки.

Выделяем строку, в которой есть все прописанные формулы, копируем ее и размножаем на столько строк, сколько нужно.
Если не понятно, то поищите в сети запроc: «Как протянуть формулы в excel?»
Остальные ячейки вы можете учитывать, а можете нет, я фиксирую источник заказа, чтобы вести аналитику. Думаю, вам пока рано этим заниматься, а когда созреете, вы это будете фиксировать, скорее всего, через метрику.

Создаем вкладку Товары

Сюда мы будем собирать всю информацию из вкладки «Заказы» тех товаров, напротив артикула которых стоит пометка «Заказать». Потом будем сортировать эти товары по поставщикам и выводить готовый итоговый удобный список товаров, которые нам нужно заказать.

В столбце А нумеруем строки 1,2,3,4,...
На эту нумерацию будет ссылаться другая формула
Ячейка B4: =ЕСЛИОШИБКА(ИНДЕКС('Заказы'!D:D;НАИМЕНЬШИЙ(ЕСЛИ('Заказы'!C:C="Заказать";СТРОКА('Заказы'!D:D);"");'Заказы'!A2));"")
Формула сканирует столбец C, ищет пометку "Заказать" и выводит SKU (артикул) товара, стоящего напротив этой пометки, который нужно заказать, начиная с самого первого упоминания этой пометки. Так как нам нужно выводить даже повторяющееся SKU (артикулы), то стандартная формула поиска "=ВПР" не подходит, так как она будет отображать лишь первый найденный результат и повторять потом его не будет.
Ячейка C4: =ЕСЛИОШИБКА(ИНДЕКС('Заказы'!G:G;НАИМЕНЬШИЙ(ЕСЛИ('Заказы'!C:C="Заказать";СТРОКА('Заказы'!G:G);"");'Заказы'!A2));"")
Аналогично с формулой выше, только она выводит количество заказанного товара, который вы указывали руками сами в столбце G (во кладке "Заказы")
Ячейка D4: =ЕСЛИОШИБКА(ВПР(B4;'Склад'!B:AL;37;0);"")
Формула смотрит на ячейку C4, фиксирует SKU (артикул) товара, идет во вкладку "Склад", ищет столбец с поставщиком, отображает того поставщика, которого вы указали напротив этого товара. Если ничего не указано, то ячейка будет пустой. Обязательно нужно указать поставщика, по нему мы и будем формировать удобный список для заказа.
Ячейка R4: =ЕСЛИ(S4="";"";ЕСЛИ(СЧЁТЕСЛИ(S$4:S4;S4)=1;СЧЁТ(R$3:R3)+1;""))
Формула сканирует столбец со SKU (артикулами) и выводит количество каждого из артикулов без дублей. Т.е., если у вас заказали один и тот же товар несколько раз, формула посчитает и сформирует список уникальных SKU (артикулов) без повторений.
Ячейка S4: =ЕСЛИОШИБКА(ИНДЕКС(B:B;НАИМЕНЬШИЙ(ЕСЛИ(D:D="ООО «ПЯТЬ ЗВЕЗД», КуклаДом™";СТРОКА(B:B);"");A4));"")
Формула сканирует столбец D на вкладке "Товары" в поисках заданного поставщика, в данном случае - ООО «ПЯТЬ ЗВЕЗД», КуклаДом™, и отображает его, если такого поставщика нет, то ячейка будет пустой.
Ячейка T4: =ЕСЛИОШИБКА(ИНДЕКС(C:C;НАИМЕНЬШИЙ(ЕСЛИ(D:D="ООО «ПЯТЬ ЗВЕЗД», КуклаДом™";СТРОКА(C:C);"");A4));"")
Процесс аналогичный процессу выше, только тут отображается количество этих заданных товаров.
Ячейка V4: =ЕСЛИОШИБКА(ВПР(СТРОКА(R1);R$4:S$100;2;0);"")
Формула ссылается на столбец R, ищет уникальную нумерацию не повторяющихся SKU (артикулов), и отображает каждый уникальный SKU (артикул) в столбец.
Ячейка W4: =ЕСЛИОШИБКА(ВПР(V4;'Склад'!B:G;6;0);"")
Формула ссылается на на ячейку V4, фиксирует ее, идет во вкладку "Склад" (где вы заполняли данные по товару), находит там название товара, соответствующее SKU (артикулу) из ячейки V4 и вписывает его в ячейку W4.
Ячейка X4: =ЕСЛИ(V4="";"";СУММЕСЛИ(S$4:S$100;V4;T$4:T$100))
Формула суммирует все товары заданного артикула в ячейке V4.
Ячейка Y4: =ЕСЛИОШИБКА(ВПР(V4;'Склад'!B:H;7;0);"")
Формула заходит в ячейку "Склад", и выводит количество товара на складе у этого SKU (артикула).
Ячейка Z4: =ЕСЛИОШИБКА(ВПР(V4;'Склад'!B:K;10;0);"")
Формула выводит оптовую цену из склада у заданного SKU (артикула).
Ячейка AA4: =ЕСЛИ(X4="";"";(X4-Y4)*Z4)
Отнимает из суммы заказанных товаров те, что есть на складе и умножает на оптовую цену.
Ячейка AB4, AC4 - аналогично процедуре с оптовыми ценами из ячейки Z4.
Ячейка AD4: =ЕСЛИ(X4="";"";AC4-AA4)
Разница между оптом и розницей, чтобы просчитать сколько же мы предварительно заработаем с заказанной партии.

В итоге получаем удобный список с товарами, рассортированными по удобным табличкам с отдельными поставщиками.
Аналогичную таблицу выводите по нужным поставщикам, добавляя табличку с нужными полями по примеру выше.

Готовый шаблон docs.google с заполненными полями, которые вы можете изменять по аналогу только на свой лад.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *